close

Вход

Забыли?

вход по аккаунту

?

lab rab os 2009

код для вставкиСкачать
 ЛАБОРАТОРНАЯ РАБОТА
Основные операции с файлами и каталогами в MS DOS
Цель работы: Практически освоить операции с файлами и каталогами в MS DOS.
Практические задания
Составить и записать последовательность операций при выполнении задания:
1. Перейти на диск D.
2. Вывести содержимое диска D.
3. Создать каталог NORMA на диске D.
4. В нем создать подкаталог DOT .
5. В каталоге DOT создайте файлы slot1.dot и slot2.doc.
6. Скопируйте файл slot1.dot в каталог NORMA.
7. Перенесите файл slot2.doc в каталог NORMA.
8. Переименуйте файл slotl.dot в каталоге DOT в vint.dot.
9. Выведите содержимое каталога NORMA. Запишите, какие файлы там расположены.
10. Выведите содержимое каталога DOT. Запишите, какие файлы там расположены.
11. В директории NORMA удалите файлы с расширением doc.
12. Скопируйте каталог DOT в корневой каталог диска D.
13. Удалите подкаталог DOT каталога NORMA.
14. Выведите содержимое корневого каталога диска D. Что в нем находится?
15. Выведите содержимое каталога NORMA. Что в нем находится?
ЛАБОРАТОРНАЯ РАБОТА
Команды операционной системы MS DOS
Цель работы: Практически освоить операции с файлами и каталогами в MS DOS.
Практические задания
Составить и записать последовательность операций при выполнении задания:
1. Перейти на диск D.
2. Просмотреть корневой каталог диска D.
3. Создать каталог 8G на диске D.
4. Перейти в созданный каталог 8G.
5. В каталоге 8G создать текстовый файл kom.txt, где описать изучаемые команды MS DOS.
6. В каталоге 8G создать текстовый файл sch.txt, и записать в него следующий текст:
Файлом называется поименованная область на диске.
7. Просмотреть созданные файлы.
8. Вернуться в корневой каталог диска D.
9. Создать в каталоге 8G подкаталоги 8А и 8В.
10. В подкаталоге 8А создать текстовый файл famil.txt, где записать данные о себе.
11. Скопировать текстовый файл kom.txt в подкаталог 8А.
12. Просмотреть скопированный файл.
13. Скопировать содержимое подкаталога 8А в подкаталог 8В.
14. Переименовать файл kom.txt в подкаталоге 8В на koml.txt.
15. Просмотреть переименованный файл koml.txt.
16. Скопировать из подкаталога 8G файл sch.txt в подкаталог 8А диска D.
17. Удалить подкаталог 8G. ЛАБОРАТОРНАЯ РАБОТА
Знакомство с организацией и размещением файлов и каталогов.
Работа с панелями Norton Commander.
Цель работы: Ознакомится с организацией и размещением файлов и каталогов. Освоить понятия каталогов, подкаталогов и надкаталогов. Научиться различать виды файлов по их расширениям: Научиться выполнять операции с панелями Norton Commander.
Практические задания
Выполните следующие операции:
1. Уберите не текущую панель с экрана.
2. Выведите эту-панель обратно на экран.
3. Уберите левую панель с экрана.
4. Уберите правую панель с экрана.
5. Выведите правую панель обратно на экран.
6. Выведите левую панель обратно на экран.
7. Поменяйте панели местами.
8. Выведите на правой панели оглавление диска D.
9. Выведите на левой панели оглавление диска С.
10. Уберите обе панели с экрана.
11. Выведите обе панели с экран.
12. Выведите на правой панели краткую форму представления информации.
13. Выведите на левой панели полную форму представления информации.
Выполните задания и ответьте на вопросы:
1. Зайдите в каталог Teacher. Отсортируйте содержимое правой панели по имени. Какой файл там расположен первым?
2. Отсортируйте содержимое левой панели по времени создания. Зайдите в подкаталог ТР каталога Teacher, какой файл имеет более раннее время создания, какой файл там расположен последним?
3. Отсортируйте содержимое правой панели по расширению. Перечислите порядок расположения файлов в корневом каталоге диска D
4. Отсортируйте содержимое левой панели по размеру. Какой размер имеет файл config.sys корневого каталога?
5. Выведите на правой панели несортированное оглавление каталога. Какая при этом закономерность расположения файлов и каталогов?
6. Перечислить файлы, содержащиеся в корневом каталоге диска D.
7. Перечислить каталоги, содержащиеся в корневом каталоге диска D.
Контрольные вопросы
1. Дать определение файла.
2. Что можно определить по расширению файла?
3. Дать определение каталога.
4. Описать комбинации клавиш для работы с панелями Norton Commander.
5. В чем различие вывода краткой и полной формы вывода информации на экран?
6. Описать способы сортировки информации на экране.
ЛАБОРАТОРНАЯ РАБОТА
Основные операции с файлами и каталогами Установка атрибутов файлов
Цель работы: Практически освоить операции с файлами и каталогами в Norton Commander. Научиться устанавливать атрибуты файлов.
Практические задания:
Выполните следующие операции: 1. Выведите на правой панели содержимое диска D.
2. Выведите на левой панели содержимое диска D.
3. На правой панели создать каталог KATALOG.
4. В нем создайте подкаталог DOC.
5. В каталоге DOC создайте файлы textl.doc и text2.doc.
6. Скопируйте файл textl.doc в каталог KATALOG. 7. Перенесите файл text2.doc в каталог KATALOG.
8. Выведите на правой панели содержимое каталога KATALOG. Запишите, какие файлы там расположены.
9. Выведите на правой панели содержимое каталога DOC. Запишите, какие файлы там расположены.
10. В директории KATALOG удалите файл text2.doc.
11. Скопируйте каталог DOC в корневой каталог диска D.
12. Удалите подкаталог DOC каталога KATALOG.
13. Выведите на правой панели содержимое корневого каталога диска D. Что в нем находится?
14. Выведите на левой панели содержимое каталога KATALOG. Что в нем находится?
15. Установите для файла textl.doc каталога KATALOG атрибут скрытый. Что произошло с файлом?
Контрольные вопросы.
1. Какие атрибуты могут иметь файлы?
2. Что означают данные атрибуты?
3. Какая клавиша служит для копирования файла?
4. Какая клавиша служит для удаления файла?
5. Какая клавиша служит для переноса файла?
6. Чем отличается копирования файла от его переноса?
7. Опишите процедуру создания каталога.
8. Как можно выделить группу файлов?
ЛАБОРАТОРНАЯ РАБОТА
Операционная система Windows XP: интерфейс программы, работа с окнами
Цель работы: Изучение интерфейса операционной системы Windows XP, ознакомление с важнейшими компонентами операционной системы Windows XP - рабочим столом и категориями объектов. Изучение основного понятия среды - понятия окна и основных его компонентов. Знакомство с органами управления, панелью инструментов и системным меню. Отработка навыков настройки внешнего вида окна.
Практическая часть:
1. Загрузите операционную систему Windows XP.
2. Какие ярлыки находятся на рабочем столе вашего компьютера?
3. Что находится на панели задач?
4. Опишите интерфейс операционной системы Windows XP на вашем компьютере.
5. Измените внешний вид указателя мыши.
6. Сделайте " шлейф " у мыши.
7. Измените скорость двойного нажатия мыши.
8. Верните все настройки мыши в исходное положение.
9. Откройте иконку " Мой компьютер " (три способа).
10. Переместите окно (два способа).
11. Измените размер окна (три способа).
12. Восстановите размер окна.
13. Распахнуть окно на весь экран (два способа).
14. Свернуть окно (два способа).
15. Как можно открыть окна после свёртывания (три способа)?
16. Закройте окно (четыре способа).
17. Откройте два окна. Как можно активизировать окна (три способа)?
18. В активном окне вызовите и уберите панель инструментов.
19. В активном окне вызовите и уберите панель состояния.
20. В активном окне вызовите системное меню. Какие команды в нем находятся?
21. Отобразите в окне крупные значки.
22. Отобразите в окне мелкие значки.
23. Отобразите в окне вывод в виде таблицы.
24. Отобразите в окне вывод в виде списка.
25. Упорядочите значки по имени, типу, автоматически.
24. Вызовите главное меню.
25. Измените текущее время.
Контрольные вопросы.
1. Дать понятие операционной системы.
2. Что такое "ярлык".
3. Дать определение интерфейса.
4. Дать определение окна.
5. Перечислите элементы окна.
6. Как вызвать системное меню окна.
7. Когда становится активным пункт системного меню окна "восстановить".
8. Что показывает строка состояния окна.
ЛАБОРАТОРНАЯ РАБОТА
Операции с файлами и каталогами. Работа с поисковой системой
Цель работы: Закрепление навыков работы с файлами и папками в операционной среде Windows XP: копирование, удаление, перемещение, переименование. Отработка приемов сортировки файлов, расположение окон. Осуществление поиска файлов по заданному имени или его части.
Практическая часть:
1. Создать файл с именем Документ1 в WordPad и поместить его на рабочем столе.
2. Создать файл, содержащий рисунок с именем Документ2 в графическом редакторе Paint и
поместить его в папку Мои документы.
3. Создать папку с именем Папка на столе и поместить ее на рабочем столе.
4. Создать на диске D папку с именем Новая папка.
5. Перенести файл с именем Документ1 в папку с именем Папка на столе.
6. Перенести файл с именем Документ2 в папку Новая папка.
7. Раскрыть на рабочем столе папки с именами Новая папка и Папка на столе.
8. Скопировать в каждую папку недостающие файлы.
9. В созданных папках создать папки второго уровня.
10. В одну из папок второго уровня скопировать файл с именем Документ1.
11. Создать в этой папке копию данного документа.
12. Переименовать файл Копия Документа1 в файл с именем Док.
13. Открыть на диске С папку Windows.
14. Сделать просмотр в виде мелких значков. Какую информацию видно на экране?
15. Сделать просмотр в виде таблицы. Какую информацию видно на экране?
16. Упорядочить значки по размеру.
17. На диске С найти все файлы и папки с именем config. Сколько их.
18. Отсортировать по имени. Какой файл стоит первым, какой последним.
19. Расположите в окне поиска сначала файлы, затем - папки.
20. Расположите файлы и папки в порядке убывания размера. Какой файл стоит первым, какой
последним.
21. На диске С найти все файлы и папки с именем config и размером не более 30 кБ.
Сколько таких файлов?
Контрольные вопросы.
1. Дать определение файла.
2. Какие есть способы упорядочения значков в окне?
3. Каким может быть вид значков?
4. Перечислите способы переименования файлов.
ЛАБОРАТОРНАЯ РАБОТА
Основные команды программы архиватора ARJ
Цель работы: Закрепление навыков работы с программой-архиватором ARJ по созданию архивного файла.
Практическая часть
1. Создать в корневом каталоге диска D: каталог FIO, для чего установить текущим диск D:, нажать клавишу F7 и в окне ввести FIO.
2. Скопировать в него файлы из каталога Norton commander, начинающиеся на букву N, для чего: на одной панели войти в каталог D:\FIO , на другой - в каталог Norton commander . На панели, отображающей Norton commander, нажать Серый плюс, в окне указать N *.* и нажать клавишу F5.
3. В каталоге D:\FIO создать подкаталог 111, для чего войти в D:\FIO, нажать клавишу F7 и в окне ввести 111.
4. Скопировать в него файлы из каталога Norton commander, начинающиеся на букву Р, для чего: на одной панели войти в каталог D:\FIO\111, на другой - в каталог Norton commander, нажать Серый Плюс, в окне указать Р *.* и нажать клавишу F5.
5. Просмотреть справку архиватора ARJ, для чего в командной строке ввести ARJ/?. Для просмотра всех окон справки нажимать клавишу Enter.
6. Перейти в каталог D:\FIO и создать архивный файл ARXIV1.ARJ из всех файлов данного каталога с помощью команды А, задав в командной строке ввести arj a arxiv1.arj.
7. Просмотреть архивный файл ARXIV1.ARJ командой L, для чего в командной строке ввести arj l arxivl.arj.
8. Протестировать архивный файл ARXIV1.ARJ с помощью команды Т, для чего в командной строке ввести arj t arxivl.arj.
9. Создать архивный файл ARXIV2.ARJ из всех файлов каталога D:\FIO, включив файлы каталога 111 с помощью команды А с ключом R, для чего в командной строке ввести arj a -r arxiv2.arj.
10. Просмотреть архивный файл ARXIV2.ARJ командой L, для чего в командной строке ввести arj l arxiv2.arj.
11. Протестировать архивный файл ARXTV2.ARJ с помощью команды Т, для чего в командной строке ввести arj t arxiv2.arj.
12. Удалить из архива ARXIV2.ARJ файл NC.EXE, используя команду D, для чего в командной строке ввести arj d arxiv2.arj nc.exe.
13. Убедиться в выполнении операции удаления, просмотрев архивный файл ARXIV2.ARJ командой L, для чего в командной строке ввести команду: arj 1 arxiv2.arj
14. Добавить в архив ARXIV2.ARJ файл NC.EXE используя команду А:, указав к нему полный путь, для чего в командной строке ввести: arj a arxiv2.arj d:\nc\nc.exe
15. Убедиться в выполнении операций добавления, просмотрев архивный файл ARXIV2.ARJ командой L.
16. Создать в каталоге D:\FIO подкаталог ARCHIV и разархивировать в него файл ARXIV1.ARJ командой Е, для чего войти в каталог D:\FIO нажать клавишу F7 в окне ввести ARCHIV, затем в командной строке ввести команду arj e arxivl.arj d:\fio\archiv; войти в каталог ARCHIV и проверить, что в нём находятся все файлы, извлечённые из архива ARXIV1.ARJ
17. Создать в каталоге D:\FIO подкаталог ARCHIV1 и разархивировать в него файл ARXIV2.ARJ командой X: arj x arxiv2.arj d:\fio\archivl, ответив утвердительно на вопрос о создании директории (нажать для подтверждения клавишу Y). Проверить содержимое каталога ARCHIV1, войдя в него.
18. Удалить файлы в каталогах ARCHIV и ARCHIV1, не удаляя сами каталоги, поочерёдно войти в каждый из каталогов, нажать Серый Плюс, выделив все файлы, указав в окне *.* и нажать клавишу F8.
Контрольные вопросы.
1. Что такое архив? Какую информацию он содержит?
2. Какие возможности предоставляет программа - архиватор ARJ.
3. Как проверить целостность архива?
4. Какие команды и режимы необходимо задавать при работе с данной программой архиватором
ЛАБОРАТОРНАЯ РАБОТА
Использование программы-архиватора RAR для создания архива
Цель работы: Закрепление навыков работы с программой-архиватором RAR по созданию архивного файла.
1. Запустить архиватор RAR и создать архив ARCHIV.RAR и самораспаковывающийся (SFX)
архив ARCHIV1.EXE из файлов в каталоге NC , в имени которых первый символ "N",используя метод сжатия Fast и защитив архив паролем.
2. Выбрать диск, нажав комбинацию клавиш Alt+D и выбрав в предложенном списке дисков
диск D:.
3. Для изменения порядка файлов в списке нажать клавишу F9, и в появившемся окне
конфигурации в группе Sort name установить флажок в варианте сортировки Name
(сортировка по именам).
4. Нажмите клавиши Серый + вызвать окно определения маски файлов, задать маску N *.* для
выделения файлов, подлежащих помещению в архив.
5. Для защиты помещаемых в архив файлов паролем следует нажать комбинацию клавиш Alt+P
и ввести пароль с повторным подтверждением. Запомните пароль, он вам будет нужен для
распаковки архива в следующем задании.
6. Выбрать метод сжатия Fast (быстрое сжатие), для чего нажать Alt+M и выбрать его в
появившемся диалоговом окне.
7. Для создания архива ARCHIV1.RAR нажать клавишу F2, задать имя ARCHIV1.
Исключить возможность перемещения файлов в архив из каталога D:\NC , не включая флажок
Move. Нажать Enter для начала архивации. Пронаблюдать протокол архивирования: на экране
появляются две диаграммы (горизонтальные полосы), отображающие ход архивации каждого
файла в отдельности и формирование архива в целом. В конце процесса выводятся краткие
сведения об объемах файлов до и после помещения в архив.
8. Для создания SFX - архива ARCHIV1.ЕХЕ повторно выделить файлы, нажать клавиши Alt +F5, задать максимальный размер архивного тома 2,88 Мбайт, задать имя. Далее действовать как в п. 7.
9. По окончании процесса архивации установить курсор в левой панели RAR на имени файла созданного архива ARCHIV1.EXE и нажать Enter для просмотра содержимого архива. На экране будет раскрыт список файлов, помещенных в архив. Щелкнуть ESC для закрытия архива. Аналогично просмотреть содержимое архива ARCHIV1.RAR.
10.Щелкнуть ESC для завершения архиватора RAR
Контрольные вопросы.
1. Чем отличается внешний вид программы-архиватора RAR от ARJ.
2. Перечислите назначение функциональных клавиш по созданию архива.
Что такое SFX-архив?
ЛАБОРАТОРНАЯ РАБОТА
Извлечение файлов из RAR - архива
Цель работы: Приобретение практических навыков работы с программой-архиватором RAR по восстановлению файлов из архива. 1. Запустить архиватор RAR и извлечь из архива ARCHIV.RAR, защищенного паролем, файлы, в
имени которых первый символ "N", а в расширении первый символ "М" в каталог D:\NEW.
2. Выбрать диск, нажав комбинацию клавиш Alt+D и выбрав в предложенном списке дисков
диск D:. Установить на левой панели информационного окна каталог, содержащий архивный
файл.
3. Установить курсор в левой панели RAR на имени файла созданного архива ARCHIV1 .RAR и
нажать Enter для просмотра содержимого архива. На экране будет раскрыт список файлов,
помещенных в архив.
4. Нажатием клавиши Серый + вызвать окно определения маски файлов, задать маску N*. M*
для выделения файлов, подлежащих извлечению из архива.
5. Для извлечения файлов из архива, закрытого паролем, нажать комбинацию клавиш Alt + Р и
ввести пароль, который вы задавали при создании архива в предыдущем задании.
6. Для извлечения помеченных файлов в заданный каталог нажать клавиши Alt + F4 и задать
имя каталога, в который следует поместить извлекаемый из архива файлы D:\NEW.
Пронаблюдать процесс распаковки архива. Если каталога D:\NEW нет, то он будет
автоматически создан архиватором RAR.
7. По окончании процесса извлечение файлов из архива щелкнуть ESC для завершения работы
архиватора RAR.
8. Просмотреть содержимое каталога D:\NEW и убедиться, что заданные файлы, в имени которых
первый символ "N", а в расширении первый символ "М", извлечены из архива в данный каталог.
Контрольные вопросы.
1. Перечислите назначение функциональных клавиш выполняющих архивные функции.
2. Как защитить архив паролем?
ЛАБОРАТОРНАЯ РАБОТА
Использование архиватора WINRAR
Цель работы: Приобретение практических навыков работы с программой-архиватором WINRAR
1. Запустить архиватор WINRAR. 2. Создать архив ARCHIVE4, поместив в архив файлы каталога NC.
Просмотреть свойства архивного файла.
3.Закрыть окно архива.
4.Открыть архив ARCHIVE4.RAR. Просмотреть файл 8662ansi.set в архиве. 5. Записать комментарий к архиву, для чего в меню Actions выбрать команду Comment и в раскрывшемся окне Comment ввести текст комментария, в котором можно описать назначение файлов архива и другие нужные вам сведения об архиве. Сохранить комментарии, щелкнув кнопку Save и закрыть окно Comment. 6.Добавить в архив ARCHIVE4.RAR файл PACKER.SET. Просмотреть свойства архивного файла и убедиться, что они изменились. 7.Извлечь из архива ARCHIVE4.RAR файлы, имеющие в имени первые два символа "85". По окончании процесса закрыть окно WINRAR.
Используя Проводник, просмотреть диск и папку, в которую извлеклись файлы из архива. Убедиться, что операция выполнена успешно.
8.Просмотреть настройки программы WINRAR.
ЛАБОРАТОРНАЯ РАБОТА
Использование справки Windows XP.
Цель работы: Практическое освоение использования справки Windows XP.
1.В Главном меню выбрать пункт Справка и поддержка. В левой области окна справки выберите пункт Новые возможности Windows XP. Изучить справочную информацию о новых возможностях Windows XP. 2.Выбрать раздел Введение в Windows XP и изучить тему Новые возможности Windows XP. Выбрав справку по вопросу Новые средства, облегчающие работу, в правой области окна
справки для получения детальной справки щелкнуть кнопку ссылки в соответствующем пункте.
Используя тему Новые возможности Windows XP, выясните, за счет чего повышается надежность и производительность компьютера в Windows XP, какие возможности предоставляет пользователю полное объединение с Web-ресурсами.
Свернуть список справки темы Новые возможности Windows XP.
3. Выбрать раздел Знакомство с компьютером и изучить справку о сочетаниях клавиш для
Windows, для диалоговых окон.
4. Найти подсказку о копировании раздела справки, для чего в левой области окна справки
выбрать вкладку Поиск, ввести ключевое слово "копирование", щелкнуть кнопку Разделы, в
списке разделов выбрать раздел Копирование раздела справки и щелкнуть кнопку Показать. В
правой области окна справки будет введен текст искомой подсказки.
5. Запустить редактор текстов WordPad и скопировать в его окно справку о сочетаниях клавиш для Рабочего стола, окна Мой компьютер и Проводника Windows, для чего, выбрав в окне справки Windows раздел Знакомство с компьютером, перейти в тему Сочетания клавиш, затем щелкнуть мышкой на пункте справки Сочетания клавиш для рабочего стола, окна "Мой компьютер" и проводника Windows. В правой области окна справки выделить текст справки и щелкнуть правую кнопку мыши для вызова контекстного меню. В контекстном меню выбрать опцию Копировать, затем перейти в окно WordPad и вставить фрагмент справки из буфера
обмена в окно документа WordPad, щелкнув Ctrl+V.
6. Используя предметный указатель, найти подсказку об изменении размера шрифтов на
экране и скопировать ее в окно документа WordPad. Для этого в левой области окна справки
выбрать кнопку Указатель, затем ключевые слова "параметры настройки", после чего в поле
списка указателя курсор укажет раздел, в котором есть эти ключевые слова. Щелкнув кнопку
Показать, вы раскроете окно со списком найденных разделов. Выбрав из них нужный, щелкнуть
кнопку Показать для вывода справки выделить текст справки, скопировать ее в буфер обмена и
вставить в окно документа WordPad.
7. Найти справку о включении специальных возможностей Windows XP. Для этого в окне
справки выбрать вкладку Поиск, ввести ключевые слова "специальные возможности", щелкнуть
кнопку Разделы, в списке разделов выбрать раздел Включение специальных возможностей и
щелкнуть кнопку Показать. В правой области окна справки будет выведен текст искомой
подсказки.
Контрольные вопросы.
1 .Какую информацию содержат Вкладки Справочной системы? 3. Как скопировать справочную информацию в редактор WordPad?
ЛАБОРАТОРНАЯ РАБОТА
Стандартные приложения Windows XP
Цель работы: Практически освоить обмен данными между приложениями Windows XP
Практическое задание:
1 .Запустить стандартные приложения текстовый редактор WordPad и графический редактор Paint. 2.В окне текстового редактора WordPad скопировать текст справки WordPad о выводе на экран панели инструментов, выполнив следующие операции:
вызвать справку WordPad, выбрав вкладку Содержание, раздел Настройки окна WordPad, перейти в тему Вывод на экран или скрытие панели инструментов;
перейти в правую область окна справки, затем вызвать контекстное меню и выбрать в нём команду Выделить всё, указав мышкой на выделенные элементы, вызвать контекстное меню и выбрать в нём команду Копировать; перейти в окно WordPad и вставить фрагмент справки из буфера обмена в окно документа WordPad, активизировав контекстное меню и выбрав в нём команду Вставить.
3. Перейти в окно графического редактора Paint. Нарисовать рисунок. Выделить рисунок, в
контекстном меню выбрать команду Копировать. Фрагмент рисунка скопировать в буфер обмена.
4. Перейти в окно WordPad, указать курсором место вставки фрагмента рисунка и вставить его из
буфера обмена, активизировать контекстное меню и выбрать в нём команду Вставить.
5. Выделить фрагмент текста в окне текстового редактора WordPad и перенести его в окно
графического редактора Paint, для чего выполнить следующие операции:
* выделить фрагмент текста в окне текстового редактора WordPad и удалить его в буфер обмена командой Вырезать из меню Правка;
* перейти в окно графического редактора Paint, включить инструмент А, задать цвет фона, курсором мыши указать размер марки текста. На панели форматирования выбрать имя, размер и начертание шрифта. Щёлкните внутри рамки надписи, вставьте текст из буфера обмена командой Вставить меню Правка. Если на экране будет выведено сообщение "Недостаточно места для вставки текста", увеличить размер рамки текста и повторить попытку вставить текст из буфера обмена.
6.Отредактировать надпись, сдвинув надпись , сдвинув надпись или изменив её размер, выбрать цвет на палитре, чтобы изменить текст текста. Щёлкнуть мышкой вне рамки текста. Редактирование текста закончено.
7.Закрыть окна текстового редактора WordPad и графического редактора Paint, не сохраняя результаты работы.
Контрольные вопросы.
1. Перечислите стандартные приложения Windows XP
2. Как произвести обмен данными между приложениями?
ЛАБОРАТОРНАЯ РАБОТА
Оптимизация размещения информации на диске
Цель работы: Изучить способы записи информации на диске, научиться проводить оптимизацию диска.
Практические задания
Выполните следующие операции:
1. Выведите содержимое диска D.
2. Проведите анализ диска D на фрагментацию файлов.
3. Просмотрите отчет об анализе фрагментации файлов. Какие сведения он содержит? Какой процент свободного места на диске?
4. Выведите содержимое диска C.
5. Проведите анализ диска C на фрагментацию файлов.
6. Просмотрите отчет об анализе фрагментации файлов. Какие сведения он содержит? Контрольные вопросы.
1. Что такое "фрагментация файла"?
2. Какой файл называется непрерывным?
3. В чем заключается оптимизация на уровне диска?
4. Для чего используется дефрагментация диска? В чём её суть?
5. С помощью какой программы можно производить дефрагментацию диска?
6. Для чего предназначена программа Scandisk?
ЛАБОРАТОРНАЯ РАБОТА Конфигурирование файлов autoexec.bat и config.sys
Цель работы: Изучить команды файлов конфигурирования системы config.sys и autoexec.bat. Практические задания
Задание 1. Ознакомиться с командами файла config.sys и записать комментарий к каждой команде.
Device=c:\windows\himem.sys Device=c:\windows\emm386.exe DOS=HIGH,UMB Country=007,866,C:\WINDOWS\COMMAND\country.sys device=C:\WINDOWS\COMMAND\display.sys con=(ega"l) DEVICE= C:\CDROM\VIDE-CDD.SYS /D:MSCD001 device=C:\WINDOWS\SETVER.EXE Задание 2. Ознакомиться с командами файла autoexec.bat и записать комментарий к каждой команде.
@echo off prompt $p $g SET TEMP=C:\WINDOWS\TEMP SET SOUND=C:\SB16 SET BLASTER=A330 19 Tl D2 PATH::=C:\WINDOWS;C:\WINDOWS\COMMAND;C:\WINDOWS\SYSTEM C:\WINDOWS\COMMAND\MSCDEX.EXE /D.-MSCDOOl /V mode con codepage prepare=((866) C:\WINDOWS\COMMAND\ega3.cpi) mode con codepage select=866 C:\WINDOWS\COMMAND\keybrd3.sys Контрольные вопросы.
1. Назначение файлов autoexec.bat и config.sys.
2. Как произвести загрузку драйверов в память?
3. Как установить удобный формат выдачи информации о дате, времени?
4. Как установить переменные окружения DOS и задать список каталогов, в которых находятся запускаемые файлы?
5. Записать состояние файлов autoexec.bat и config.sys, находящиеся на вашем компьютере.
ЛАБОРАТОРНАЯ РАБОТА
Операции с дисками, папками и файлами в приложении Проводник.
Цель работы: Научиться работать с программой Проводник.
1. Запустить Проводник. Открыть в правом окне Проводника содержимое диска D:, для чего щелкнуть кнопку ∆ в строке Адрес, а затем в списке дисков и папок выбрать диск D:
2. Задать вид отображения папок и файлов в окне Проводника в виде таблицы, для чего в меню Вид выбрать опцию Таблица.
3. Упорядочить размещение значков папок и файлов по дате последнего изменения, щелкнув в правой части окна Проводника на заголовке графы Изменён.
4.Упорядочить размещение значков папок и файлов по алфавиту имён, щёлкнув в правой части окна Проводника на заголовке графы Имя.
5. Создать в корневой директории диска D: папку с именем 1111, для чего, щёлкая кнопки Назад, Вперёд, задать в правом окне Проводника отображение в корневой директории диска D:, установив курсор в правом окне, вызвать контекстное меню и вызвать команду Создать. В раскрывшемся списке создаваемых объектов выбрать Папку, задать имя созданной папки 1111.
6. Создать в папке 1111 текстовый файл Пример1.tхt, для чего открыть папку 1111, в контекстном меню выбрать команду Создать, затем в списке создаваемых объектов выбрать тип создаваемого файла: - текстовый документ и задать имя Пример1.txt
7. Создать папку 2222 в корневой директории диска D: и скопировать в неё файл Пример1.tхt из папки 1111. Создать папку 2222. Перейти в папку 1111, установив курсор на файл Пример1.txt, вызвать контекстное меню. В этом меню выбрать команду Копировать. Перейти в папку 2222 и в контекстном меню выбрать команду Вставить.
8. Переименовать файл Пример1.txt в папке 2222 на диске D: в файл Пример2.txt.
9.Удалить файл Пример2.tхt в папке 2222 с помощью меню Файл.
10. Удалить папку 2222 с диска D: с помощью меню Файл.
Контрольные вопросы
1 .Для чего предназначена программа Проводник?
2. Что показано в левой части программы Проводник?
3. Как произвести копирование, перемещение файлов при помощи программы Проводник?
4. Как развернуть, раскрыть папку?
ЛАБОРАТОРНАЯ РАБОТА
Операции с дисками, папками и файлами в Total Commander
Цель работы: Ознакомится с организацией и размещением файлов и каталогов. Научиться различать виды файлов по их расширениям: 1. Запустите Total Commander. Откройте в левом файловом окне содержимое диска С.
2. Задайте Подробный вид отображения папок и файлов в левом окне Total Commander в виде таблицы.
3. Упорядочите размещение значков папок и файлов в левом окне по дате последнего изменения. Отсортируйте значки папок и файлов в правом файловом окне по алфавиту имен.
4. Создайте в корневом каталоге диска D: папку с именем 1111. Откройте в левом окне каталог 1111.
5. Установите активным правое файловое окно. Задайте отображение на правой панели каталога Мои документы. Скопируйте из каталога Мои документы файлы с расширением *.txt. Для выделения группы файлов в меню Выделение выберите команду Отметить группу, затем в окне Добавить выделение укажите шаблон *.txt и щелкните кнопку ОК. 6. Упакуйте файлы в папке D:\1111 в архив, для чего, выделив все файлы в папке D:\1111 в левом окне, выберите в меню Файл команду Упаковать. Затем в окне Упаковка файлов задайте имя каталога для размещения архива, включите опции Сохранять пути, Рекурсивная упаковка подкаталогов и выберите архиватор ZIP. Имя файла архива оставьте по умолчанию 1111. Для начала архивации щелкните кнопку ОК.
7. Разбейте файл архива 1111 на части, для чего, указав файл, выберите в меню Файл команду Разрезать файл. В окне Разрезание файла на куски задайте размер частей (можно выбрать размер частей из списка, а можно задать с клавиатуры, например, 15 Кб) и щелкните ОК.
8. Удалите файл архива 1111.ZIP из каталога D:\ 1111.
9. Склейте файл 1111.ZIP из отдельных частей, для чего, указав файл 1111.CRC, выберите в меню Файл команду Склеить файл, а затем в окне Склеивание кусков задайте имя диска и каталога D:\1111 и щелкните кнопку ОК для начала операции сборки файла из частей. По окончании сборки закройте окно сообщения, щелкнув кнопку ОК.
10. Найдите и просмотрите содержимое файла History.txt. Выбирая в меню Параметры различные параметры просмотра, пронаблюдайте изменение в окне Lister. После просмотра файла закройте окно Lister.
11. Закодируйте файл History.txt, для чего, указав файл, выберите в меню Файл команду Кодировать. В окне Кодировать укажите каталог для размещения закодированного файла, например D:\llll, выберите способ кодирования (MIME [Base64], UUEncode или XXEncode) и щелкните кнопку ОК для начала операции кодирования.
12. Просмотрите содержимое закодированного файла History (расширение кодированного файла указывает на способ кодирования, например, Ь64 означает, что файл закодирован способом MIME [Base64]), для чего, указав файл History.b64, нажмите клавишу F3 Просмотр. Убедитесь в том, что файл закодирован. После просмотра файла закройте окно Lister.
13. Декодируйте файл History.b64, для чего, указав файл, выберите в меню Файл команду Декодировать. В окне Декодировать укажите каталог для размещения декодированного файла и щелкните кнопку ОК для начала операции декодирования. Просмотрите содержимое декодированного файла History.txt и после просмотра файла закройте окно Lister.
14. Измените настройки Total Commander, для чего выберите в меню Конфигурация команду Разное. В окне Установки, выбрав вкладку Вид, включите опцию Кнопки дисков. Выбрав вкладку Просмотр/Редактирование, в поле Редактор по F4 задайте внешнюю программу-редактор, например, редактор WordPad, размещенный в папке C:\WINDOWS\system32\write.exe (или иной редактор текстов). Выбрав вкладку Цвет, измените цвет текста, фона и выделения по вашему усмотрению. Выбрав вкладку Архиваторы, определите имена архиваторов для использования. Выбрав вкладку Zip-архиватор, выберите степень сжатия Максимальное. Для вступления в силу внесенных в настройку Total Commander изменений щелкните кнопку Применить и закройте окно Установки, щелкнув кнопку ОК.
15. Измените состав кнопок в панели инструментов Total Commander, для чего выберите в меню Конфигурация команду Панель инструментов. В окне Настройка панели инструментов добавьте кнопку для запуска программы Калькулятор. Для этого, щелкнув кнопку Добавить, задайте в поле Команда имя файла calc.exe, в поле Путь запуска - C:\WINDOWS\system32\, в поле Файл значка - C:\WINDOWS\system32\calc.exe, как показано на рис. 3.21. В поле Подсказка введите текст "Калькулятор". Завершите добавление кнопки вызова калькулятора в панель инструментов, щелкнув кнопку ОК.
16. Измените меню Запуск, добавив в него команду запуска графического редактора Paint. Для этого выберите в меню Запуск команду Изменить меню Запуск, затем в окне Настройка меню Запуск щелкните кнопку Добавить элемент, и, задав название элемента меню "Графический редактор Paint", щелкните кнопку ОК. Щелкнув кнопку " (Просмотр), в окне Просмотр найдите папку C:\WINDOWS\system32\, в ней найдите файл программы mspaint.exe и щелкните кнопку ОК. Затем в окне Настройка меню Запуск задайте путь запуска программы C:\WINDOWS\system32\, "горячие клавиши" и, щелкнув кнопку ОК, закройте окно Настройка меню Запуск. Проверьте изменения меню Запуск, выбрав меню Запуск и просмотрев список команд в нем. Выбирая команды в меню Запуск, проверьте их действие. Закройте окна приложений, открытые при проверке меню Запуск.
17. Сохраните изменения в настройках Total Commander, выбрав в меню Конфигурация команду Сохранить настройки.
18. Закройте окно Total Commander.
Контрольные вопросы
1. Каковы отличительные особенности файл-менеджера Total Commander от стандартного приложения Проводник Windows?
2. Опишите назначение элементов окна Total Commander.
3. В чем преимущества использования двух файловых окон в файл-менеджере Total Commander?
4. Каковы особенности меню Total Commander?
5. Какие параметры переименования выделенных файлов допустимы в Total Commander?
6. Для чего нужно меню Запуск?
Содержание
1. Основные операции с файлами и каталогами в MS DOS.
2. Команды операционной системы MS DOS.
3. Знакомство с организацией и размещением файлов и каталогов.
Работа с панелями Norton Commander.
4. Основные операции с файлами и каталогами в Norton Commander. Установка атрибутов файлов.
5. Операционная система Windows XP: интерфейс программы, работа с окнами.
6. Операции с файлами и каталогами. Работа с поисковой системой в ОС Windows XP.
7. Использование справки Windows XP.
8. Стандартные приложения Windows XP.
9. Операции с дисками, папками и файлами в приложении Проводник.
10. Операции с дисками, папками и файлами в Total Commander.
11. Оптимизация размещения информации на диске
12. Конфигурирование файлов autoexec.bat и config.sys
13. Основные команды программы архиватора ARJ.
14. Использование программы-архиватора RAR для создания архива.
15. Извлечение файлов из RAR - архива.
16. Использование архиватора WINRAR.
Документ
Категория
Рефераты
Просмотров
204
Размер файла
180 Кб
Теги
2009, lab, rab
1/--страниц
Пожаловаться на содержимое документа