close

Вход

Забыли?

вход по аккаунту

?

отчёты

код для вставкиСкачать
ПРАКТИЧНА РОБОТА № 1.
Тема : "Робота з програмою "Проводник".
1. Мета роботи : 1.1 Навчитись працювати з програмою "Проводник".
1.2 Навчитись працювати з папками .
1.3 Навчитись працювати з файлами .
2. Обладнання : 2.1 ПК , методичні вказівки до виконання роботи.
Питання до самоконтролю.
1. Які типи об'єктів застосовують у Windows ?
2. Що на робочому столі на робочому столі при вмиканні комп'ютера ?
3. Для чого призначена "Панель завдань" ?
4. Для чого призначена кнопка "Пуск" ?
5. Які функції виконують кнопки, розташовані на панелі інструментів ?
6. Для чого використовують кнопки управління вікном ?
7. Як виділяють групи об'єктів ?
Відповіді на питання.
1. У Windows використовують такі типи об'єктів : папки, файли, програми, ярлики, піктограми.
2. При вмиканні комп'ютера на робочому столі зображуються Панель завдань і піктограми Мій комп'ютер, Кошик, Мої документи та деякі інші піктограми.
3. На панелі завдань відображаються такі важливі елементи : кнопка Пуск, індикатор перемикання мови, годинник, кнопки відкритих і згорнутих вікон документів, програм.
4. Кнопка Пуск призначена для запуску програм в роботу.
5. На панель інструментів винесені кнопки найбільш часто використовуваних команд.
6. Кнопки керування вікном використовують для операцій над вікнами : згорнути, розгорнути і закрити вікно.
7. Для того, щоб відмітити об'єкти, потрібно натиснути клавішу Ctrl і, не відпускаючи її, по черзі вибирати об'єкти курсором миші шляхом натискання лівої клавіші.
Якщо об'єкти знаходяться підряд потрібно відмітити мишею перший, натиснути клавішу Shift і, не відпускаючи її, зафіксувати курсор миші на останньому об'єкті, а тоді натиснути на ньому ліву клавішу.
Щоб відмітити всі об'єкти в активній папці, потрібно в пункті меню "Правка" вибрати команду "Выделить все".
Завдання до виконання роботи.
1. Завантажити програму "Проводник" у роботу. Перетворіть поточне вікно у піктограму та навпаки. Установіть у поточному вікні нормальний розмір вікна. Перетворіть його у повноекранний та навпаки. Зменшить, а потім збільшить розмір поточного вікна.
2. Створіть у папці "Мои документи" свою папку. Потім у неї створіть свій текстовій файл.
3. Скопіювати свій файл у іншу папку. Потім перейменувати свій файл. Виділити групу файлів у іншій папці і перенести їх в свою папку. 4. Знищіти свій файл у Корзину,а потім його відновити.
ПРАКТИЧНА РОБОТА № 2.
Тема : "Робота з архіватором WinRAR".
1. Мета роботи : 1.1 Навчитись створювати свій архів.
1.2 Навчитись користуватися командами архіватора RAR. 2. Обладнання : 2.1 ПК, методичні вказівки до виконання роботи.
Питання до самоконтролю.
1. Що таке стиснення даних ?
2. Які є методи стиснення ?
3. Для чого архівуються файли ?
4. Чому WinRAR більш універсальна, чим WinZip ?
5. Яка структура вікна архіватора WinRAR ?
6. Як створюється архів в класичному режимі ?
1. Стиснення (компресія) даних - це процес перетворення даних, при якому зменшується надмірність у їх поданні і, відповідно, обсяг пам'яті для їх збереження.
2. Їїх можна розділити на дві групи - стиснення без втрат та стиснення із втратами. У випадку стиснення без витрат розпаковане повідомлення точно повторює вхідне (так можна опрацьовувати будь-які дані). Стиснення із втратами можливе тільки в тих випадках, коли допустимі деякі спотворення (які саме, залежить від конкретного типа даних).
3. Для зменшення розмірів файлів. 4. Програма WinRAR використає власний алгоритм стиску даних. Цей алгоритм працює небагато повільніше, ніж, наприклад, алгоритм Zip, але зате забезпечує більше високий ступінь стиску. Інші програми- архіваторы не можуть працювати з RAR- архівами, але сама вона успішно працює як із власними, так і з Zip- архівами. Тому WinRAR більше універсальна, чим WinZip.
5. Рядок назви, рядок меню, панель інструментів, піктографічне меню, робоче поле, рядок стану.
6. Для створення архіву й додавання файлів до існуючого використається та сама кнопка Додати. Щоб створити архів, у вікні програми вибрати файл або папку, яку потрібно заархівувати, і клацнути на кнопці Додати. Слід зазначити, що в діалозі можна вибрати кілька файлів, виділяючи їх у списку щигликом миші при натиснутій клавіші Ctrl. При цьому можна виділити кілька файлів, розташованих у різних місцях списку. На екрані з'явиться діалогове вікно Ім'я й параметри архіву. Необхідно ввести в поле Архів ім'я створюваного архіву. Якщо ви хочете додати до нього інші файли або папки, клацнути на кнопці Огляд. За допомогою перемикача Формат архіву задати алгоритм стиску даних. Вибираємо RAR. Далі вибираємо в цьому ж вікні зі списку Метод стиску ступінь стиску файлів. Чим вище ступінь стиску, тим менше швидкість роботи з архівом і більше ймовірність помилок.
Завдання до виконання роботи.
1. Створити в папці Мои документы свою папку, в якій створити 4 невеликих файли. Потім створити свій архів, до якого за архівувати 2 файли без видалення їх, а інші два файли з видаленням з папки. 2. Проглянути свій архів та файли в архіві за допомогою кнопки перегляду.
3. Розархівувати два файли, які були заархівовані з видаленням. 4. Протестувати свій архів.
5. Видалити у архіві один з файлів.
6. Додати до файлів, що залишилися в архіві, коментар. 7. Створити архів, що саморозпаковується.
ПРАКТИЧНА РОБОТА № 3.
Тема : "Створення документу. Створення шаблону документу. Робота з графікою у Word".
1.Мета роботи : 1.1 Навчитись працювати в текстовому редакторі Word ".
1.2 Ознайомитись з основними технологіями створення текстових документів. 1.3 Навчитись працювати з фрагментами тексту.
2. Обладнання : 2.1 ПК , методичні вказівки до виконання роботи.
Питання до самоконтролю.
1. Як створити новий документ?
2. Які засоби має редактор для введення, редагування символів?
3. Як можна редагувати виділений фрагмент?
4. Які можливості щодо форматування документів має Word?
5. Дайте визначення "Шаблон документа".
6. Як вставити таблицю в текст?
1. При створенні нового документа слід подати команду Файл/Создать або натиснути відповідну кнопку панелі інструментів Стандартная. При цьому відкривається вікно діалогу Создание документа. Створюючи документ, у полі Новий документ слід встановити опцію Документ.
2. Вводити і редагувати можна тільки текст активного вікна. Перед введенням символів слід вибрати шрифт, його розмір, формат. Символи можуть вводитись у режимі заміни або вставки. В першому випадку введений символ заміщає той символ, на якому знаходився курсор. В режимі вставки частина рядка, що розміщена праворуч від курсору, зсувається на одну позицію і символ вводиться на звільнене місце. Переключення між режимами здійснюється клавішею [Ins]. Для вилучення символа ліворуч від курсору слід натиснути клавішу [Backspace], а символа в позиції курсору - клавішу [Del]. При цьому курсор переміщається на одну позицію ліворуч. Коли курсор доходить до кінця рядка, то перше слово, яке не вміщається в даному рядку, повністю переноситься в наступний.
3. Його можна вилучити, скопіювати,перемістити, змінити у ньому шрифт.
4. Під форматуванням розуміють операції, які зв'язані з оформленням тексту і зміною його зовнішнього вигляду. Операції форматування дійсні тільки для виділених фрагментів.
Розрізняють три основні операції форматування: форматування символів; форматування абзаців; форматування сторінок.
5. Шаблон - це порожній бланк, в якому користувач заповнює потрібні поля своєю інформацією.
6. Для вставлення в документ таблиці необхідно установити курсор у місці, де повинна починатися таблиця та в меню Таблица вибрати пункт Добавить, потім Таблица. У діалоговому вікні, що з'явилося, слід увести число стовпців і рядків, і натиснути ОK.
Завдання до виконання роботи.
1. Набрати виданий викладачем текст, встановити відступи, міжстрічковий інтервал, шрифт.
2. Навчитися переміщувати та копіювати фрагменти тексту.
3. Навчитися зміняти шрифт у фрагменті, копіювати його в інше вікно.
4. Побудувати таблицю за зразком та розфарбувати її. ПРАКТИЧНА РОБОТА № 4 .
Тема : "Застосування вкорінених додатків у середовищі Word. Буфер обміну. Вставка малюнків". 1. Мета роботи : 1.1 Навчитись працювати з редактором формул в текстовому редакторі Word .
1.2 Ознайомитись з основними принципами роботи з буфером обміну. 1.3 Навчитись вставляти малюнки в текст.
2. Обладнання : 2.1 ПК , методичні вказівки до виконання роботи.
Питання до самоконтролю.
1. Як викликати редактор формул Microsoft Equation 3.0?
2. Яким чином можна ввести корінь кубічний?
3. Як можна редагувати формули?
4. Для чого призначений буфер обміну?
5. Як вставити малюнок в текст?
6. Як змінити параметри малюнку?
1. Через команду Объект з пункту меню Вставка. При цьому відкривається вікно, в якому потрібно вибрати закладку Создание і в списку вибрати - Microsoft Equation 3.0.
2. Щоб у формулі ввести корінь кубічний, слід визначити в якому із списків знаходиться шаблон кореня довільного степеня, тоді вибрати його мишею. У полі для редагування формули з'являється відповідний математичний символ. Після цього, за допомогою миші або клавіш керування курсором, перейти в позицію показника степеня і ввести цифру З, а тоді, перейшовши в середину символу "корінь", ввести підкореневий вираз.
3. Якщо користувачу потрібно зробити зміни у вже створеній раніше формулі, то слід двічі натиснути ліву клавішу миші на відповідній формулі. При цьому завантажується редактор формул. 4. Буфер обміну призначений для зберігання фрагмента тексту з метою його копіювання чи переміщення як у межах документа, так і в інші документи.
5. Для розміщення графіки слід встановити курсор у місце, де планується розміщення. Після цього потрібно виконати команду Вставка/Рисунок. На екрані з'явиться вікно діалогу Вставка рисунка. У цьому вікні слід вибрати дисковод, папку та ім'я файла. Ім'я файла вибирається із списка Имя. У списку знаходяться файли, тип яких вказано в однорядковому списку Тип файла.
6. Щоб змінити масштаб і положення графіки в документі, потрібно виділити графіку. Для цього слід сумістити курсор миші з графічним зображенням і натиснути кнопку миші. Команда Формат/Рисунок викличе на екран вікно діалогу Рисунок. Використовуючи це вікно, можна змінити масштаб, відстань між текстом і графікою.
Завдання до виконання роботи.
1. Виконати запропоновані викладачем завдання.
ПРАКТИЧНА РОБОТА № 5 .
Тема : " Створення комп'ютерної презентації ".
1. Мета роботи : 1.1 Навчитись створювати комп'ютерні презентації.
2. Обладнання : 2.2 ПК , методичні вказівки до виконання роботи.
Питання до самоконтролю.
1. Що таке презентація ?
2. З якими об'єктами працює PowerPoint ?
3. Як змінити формат тексту ?
4. Як додати новий слайд ?
5. Як дублювати слайд ?
6. Як видаляти слайди ?
7. Як застосувати шаблон оформлення ?
8. Які є способи введення графічних об'єктів у слайд ?
1. Презентація ( англ. "presentation" ― представлення) ― це набір кольорових карток- слайдів.
2. Об'єктом обробки PowerPoint є файл презентації, який має довільне ім'я та розширення .ppt. В цей файл входять структурні елементи презентації ― слайди разом з додатковою інформацією. 3. Змінити формат тексту можна за допомогою панелі інструментів Форматирование або у вікні діалогу Шрифт.
4. Для цього :
4.1 виділити слайд, після якого буде розташований новий;
4.2 виконати команду Вставка/Создать слайд;
4.3 за потребою в області задач Разметка слайда вибрати інший макет слайда;
4.4 виконати команду Правка/ Объект-слайд, щоб перейти у звичайний режим для подальшої роботи над слайдом.
5. Для цього :
5.1 виділити слайд чи групу слайдів;
5.2 виконати команду Правка/ Дублировать.
6. Для цього :
6.1 виділити слайд чи групу слайдів;
6.2 виконати команду Правка/Очистить або натиснути клавішу Delete (слайди, які залишилися, будуть перенумеровані).
7. Щоб застосувати шаблон оформлення, треба :
a. перейти в режим упорядника слайдів(команда Вид/Сортировщик слайдов);
b. виконати команду Формат/Оформление слайда, щоб відкрити область задач Дизайн слайда);
c. виділити групу слайдів, якщо шаблон всієї презентації змінювати не потрібно;
d. навести вказівник на зразок потрібного шаблону, натиснути кнопку, яка з'явилася праворуч, щоб відкрити список можливих дій;
e. застосувати шаблон оформлення для виділених слайдів або для всієї презентації.
8. Для цього :
a. вибрати авто розмітку із групи Макеты содержимого (макети відрізняються кількістю об'єктів, що можна розташувати на слайді, наприклад, одна рамка ― один об'єкт, дві рамки ― два об'єкти);
b. клацнути значок у рамці на слайді (таблиця, діаграма, малюнок із файлу тощо) ― відкрите вікно діалогу відповідатиме вибраному об'єкту.
Завдання до виконання роботи.
1. Складіть презентацію згідно вказівки теми викладачем.
2. У презентацію вставити малюнки. ПРАКТИЧНА РОБОТА № 6 .
Тема : "Створення стандартних публікацій."
1. Мета роботи : 1.1 Навчитись створювати швидки публікації : резюме, бланки, буклети, бюлетні, календарі, конверти, привітання тощо. 2. Обладнання : 2.1 ПК , методичні вказівки до виконання роботи.
Питання до самоконтролю.
1. Яке призначення програми MS Publisher ?
2. Які є заготовки публікацій для друку ?
3. Які є зразки макетів ?
4. Які є кольорові і шрифтові схеми ?
5. Які є види резюме ?
6. Яке призначення текстових блоків ?
7. Що таке стиль ?
8. Як застосовують стилі ?
1. Видавнича система Microsoft Publisher призначена для підготовки професійних публікацій.
2. Заготовок є декілька десятків :
* Швидки публікації ─ універсальна заготовка для створення плакатів, оголошень тощо;
* Оголошення;
* Брошури;
* Брошури з прайс-листом;
* Візитки;
* Календарі;
* Каталоги;
* Вітальні картки;
* Запрошення;
* Наклейки;
* Бланки листів;
* Газета;
* Резюме;
* Сертифікати;
* Баннери;
* Програмки та ін.
3. Зразків макетів для кожної заготовки є близько вісімдесяти : Астро, Метелик, Букет, Хвилі та ін.
4. До зразка макета користувач може застосувати кольорову схему до вподоби зі списку : Альпійску, Гори, Гранат, Дощ, Захід тощо, а також шрифтову схему : Архівну, Базову, Віртуальну тощо. 5. Є три види резюме :
* початкового рівня;
* хронологічне;
* біографічне.
6. Головним об'єктом є текстовий блок, який називають кадром (написом) у текстовому редакторі MS Word.
На сторінці може бути один чи декілька текстових блоків. У режимі роботи з об'єктами текстові блоки прийнято переміщати і змінювати їхні розміри з метою надання абзацам тексту потрібного вигляду. Текстовий блок може містити картинки, таблиці тощо. Таблиця тут також є об'єктом, її можна переміщати в середині блоку. 7. Стиль ─ це сукупність значень параметрів форматування абзацу.
8. Стилі застосовують так. Спочатку курсор розміщують у деякому абзаці. Розкривають список стилів і вибирають потрібний ─ текст у цьому абзаці зміниться відповідно до параметрів стилю. ПРАКТИЧНА РОБОТА № 7 .
Тема : "Пошук інформації в Internet. Електронна пошта."
1. Мета роботи : 1.1 Навчитись створювати пошук необхідної інформації в Internet .
1.2 Навчитись працювати з командами електронної пошти. 1.3 Засвоїти основні прийоми роботи з програмою Microsoft Outlook Express.
1.4 Набути практичних навичок створення, одержання та відправлення електронного повідомлення.
1.5 Навчитися використовувати один із поштових серверів для реєстрації електронної поштової скриньки.
2. Обладнання : 2.1 ПК , методичні вказівки до виконання роботи.
Питання для самоконтролю :
1. Що є основою пошукових систем ?
2. Які загальні принципи складання запитів ?
3. Які є засоби для швидкого переходу до потрібних ресурсів Internet ?
4. Що означає "розумний пошук" ?
5. Що таке "електронні каталоги" ?
6. Що таке електронна пошта ?
7. Чому вхід у поштові системи захищають паролем ?
1. Основою пошукових систем є так називані пошукові машини, або автоматичні індекси.
2. Загальні принципи складання запитів такі :
a. У запит варто включати кілька слів, що визначають предмет пошуку.
b. Результат пошуку буде набагато краще, якщо запит складається з декількох зв'язаних один з одним слів.
c. Можна використовувати синоніми. Якщо отриманий список результатів містить занадто мало корисних документів, треба спробувати замінити шукане слово синонімом.
d. Перевіряйте орфографію. Якщо система не знайшла жодного документа, що містить задане слово, то варто перевірити правильність його написання.
3. Для швидкого переходу до потрібних ресурсів Internet існують спеціальні засоби: якщо відомо адресу інформаційного ресурсу, то можна ввести його в рядку Адреса. 4. В Інтернету передбачена можливість "розумного" пошуку. Для цього використовується "Помічник по пошуку". Можна вибрати категорію пошуку : 1) пошук Web-сторінки;
2) попередній пошук
5. Крім пошукових систем в Інтернету є також електронні каталоги документів, що, на відміну від автоматичних індексних систем, складаються й упорядковуються при участі людини. Такі системи містять інформацію про меншу кількість ресурсів, але форма представлення і методи сортування матеріалу вигідно відрізняють них від більшості індексних пошукових систем. Ресурси в каталогах упорядковані і розподілені по тематичних категоріях.
6. Робота електронної пошти базується на принципі, що будь-який текст, набраний на клавіатурі, можна передати на другий комп'ютер, навіть на комп'ютер, розміщений на іншому континенті, якщо вони з'єднані між собою.
7. Вхід у поштові програми в системах колективного доступу захищений паролем, який треба зберігати в таємниці для захисту інформації.
Практична робота № 8.
Тема: "Розробка лінійних і розгалужених алгоритмів ".
1 . Мета роботи :
1.1 Закріпити поняття лінійних та розгалужених алгоритмів.
1.2 Вміти будувати блок схеми.
1.3 Вміти виконувати практичне завдання .
2. Обладнання :
2.1 ПК , методичні вказівки до виконання роботи.
Питання для самоконтролю :
1. Що таке алгоритм?
2. Які є засоби опису алгоритмів ?
3. Який алгоритм називається лінійним?
4. Чим відрізняється лінійний алгоритм від розгалуженого?
5. Структура команди розгалуження?
1. Алгоритм зрозуміле й точне розпорядження виконавцеві виконати скінченну послідовність команд, що приводить від вихідних даних до шуканого результату.
2. Словесний опис : алгоритм у вигляді інструкції написаної словами (рідною мовою).
Формульний : у вигляді формули розв'язується задача (одне рівняння або система рівнянь, з фізики наприклад закон Ома і т .п.).
Блок-схема : наочний графічний спосіб подання алгоритму, який входить в ЄСКД та ЄСТПД.
Табличний : запис алгоритму у вигляді таблиці.
3. Лінійним або алгоритмом послідовності називають алгоритм, складений з послідовних операцій, що виконуються один раз у порядку їх послідовності.
4. Що у ньому не має блоку перевірки умови.
5. вхід якщо умова
то дія 1
умова інакше дія 2
так ні все
вихід
Практична робота № 9.
Тема: Циклічні алгоритми. Поняття величин. Типи величин.
1. Мета роботи :
1.1 Закріпити поняття о циклічних алгоритмах та вміти використовувати їх при обчисленні найпростіших циклічних програм.
1.2 Скласти блок-схему та її алгоритм.
2. Обладнання :
2.1 ПК, методичні вказівки до виконання роботи.
Питання для самоконтролю :
1. Яка програма називається циклічною?
2. Структура команди циклу?
3. Блок-схема команди циклу?
4. Як працює команда присвоювання?
5. Які типи величин вам відомі ?
1. Цикл ― це команда виконавцеві багаторазово повторити зазначену послідовність команд.
2. доки умова
пц
серія команд кц
3. Загальна схема циклу
вхід
так перевірка умови ні серія
вихід
4. Присвоювання значень здійснюється роздільно для кожної величини. У прямокутнику можна записувати кілька вказівок про присвоювання значень величинам.
5. Кожна величина є характеристикою тіла, чи фігури або процесу. Типи величин : числові, символьні, графічні, табличні.
Практична робота № 10.
Тема: "Вивчення інтерфейса середовища програмування DELPHI. Вивчення властивостей форми".
1. Мета роботи:
1.1 Навчитися входити у середовище програмування DELPHI.
1.2.Знати назву 4-х основних вікон системи програмування. 1.3.Вмити запускати програму
2. Обладнання: 2.1 ПК, методичні вказівки до практичної роботи.
Питання до самоконтролю.
1. Які існують назви основних вікон в системі програмування?
2. Для чого існує головне вікно ?
3. Для чого існує вікно проектувальника форми?
4. Для чого існує вікно інспектора об'єктів?
1. Існують такі вікна :
1) Головне вікно(Delphi7-Project1).
2) Вікно з формою для проектування застосування(заголовок Form1).
3) Вікно інспектора об'єктів (Objekt Inspector).
4) Вікно редактора форм(Unit1.Pas).
2. Головне вікно здійснює основні функції керування проектом створеної програми.
3. Вікно проектувальника форми -головне місце, де відбувається збірка програми з компонентів,які входять в палітру компонентів.
4. Вікно інспектора об'єктів ─ відображає властивості, активізованого клацанням "миші" якого-небудь компонента або форми. Ім 'я активізованого компонента знаходиться під заголовком вікна.
Практична робота № 11.
Тема: "Програмна зміна властивостей об'єктів".
1. Мета роботи:
1.1 Навчитися відкривати новий проект.
1.2 Навчитися розміщувати в формі слідуючи компоненти Label , Button.
1.3 Вміти зберігати програму.
2. Обладнання: 2.1 ПК, методичні вказівки до практичної роботи.
Питання до самоконтролю.
1. Що являє собою середовище Delphi 7 ?
2. За допомогою чого вікна майбутньої програми готуються у вигляді форм?
3. Яким чином настроюються властивості компонентів?
4. Для чого існує компонентний підхід для створення програми в середовищі Delphi 7 ?
1. Середовище Delphi 7 являє собою інтегровану оболонку розробника, в яку входить набір спеціальних програм, відповідальних за різні етапи створення готового додатку.
2. В системі Delphi 7 є спеціальний проектувальник форм, за допомогою якого вікна майбутньої програми готуються у вигляді форм. Проектувальник дозволяє підібрати оптимальні розміри вікон, розмістити і налаштувати всілякі елементи управління та меню, додати готові зображення, вказати заголовки, підказки, написи і так далі.
3. Властивості компонентів у процесі проектування форми настроюються за допомогою Інспектора об'єктів. Це спеціальна програма, що показує список всіх властивостей даного компонента, відсортованих за категоріями або в алфавітному порядку.
4. Компонентний підхід до створення програм дозволяє повторно використовувати готові розробки і в багатьох випадках значно підвищувати ефективність праці.
Практична робота № 12.
Тема: " Арифметичні вирази. Оператори введення-виведення READ-WRITE. ".
1. Мета роботи :
1.1. Закріпити поняття лінійних та розгалужених алгоритмів.
1.2. Вміти будувати блок-схеми.
1.3. Вміти виконувати практичне завдання .
2. Обладнання :
2.1 ПК, методичні вказівки.
Питання для самоконтролю :
1. Яка програма називається лінійною ?
2. Які існують оператори введення ? Чим вони відрізняються ?
3. Які існують оператори виведення ? Чим вони відрізняються ?
4. Яка форма запису оператора присвоювання ?
1. Лінійна програма на мові ПАСКАЛЬ складається із послідовних операторів.
2. Оператор присвоювання; оператор введення даних READ, READLN.
3. Для виведення даних на екрані слугують оператори виведення WRITE та WRITELN.
4. Загальна форма запису оператора : В:= А , тут В ім'я змінної, := знак присвоювання, А вираз. Даний оператор обчислює значення виразу А, яке стоїть праворуч від знака присвоювання, та присвоює отримане значення змінній В, яка стоїть ліворуч.
Практична робота № 13.
Тема: Умовний оператор Іf...Тhen...Еlse.
1. Мета роботи :
1.1 Навчитися працювати з оператором IF...THEN...ELSE; 1.2 Навчитися складати програми на мові TURBOPAS, використовуючи умовний оператор ; 1.3 Скласти блок-схему програми ;
1.4 Скласти програму ;
2. Обладнання :
2.1 ПК, методичні вказівки до виконання роботи.
Питання для самоконтролю :
1. Структура команди IF...THEN ...ELSE ? 2. Структура команди CASE...OF ?
3. Який алгоритм називається розгалуженим?
4. Чим відрізняється лінійна програма від розгалуженої ?
1. Повна форма оператору має вигляд : IF логічний вираз THEN оператор1 ELSE оператор2 . Тут IF ( якщо ) ,THEN (тоді) , ELSE ( інакше) - службові слова; оператор 1 , оператор2 - прості, або складені оператори .
2. Загальний вигляд оператора варіанта :
CASE (ВИРАЗ) OF
(список міток варіанта) : (оператор) ;
...
(список міток варіанта) : (оператор) ;
END.
3. Розгалужені алгоритми, в яких передбачені варіанти описів, в залежності від зміни умов (тобто перевірки умов "якщо - тоді " в обов'язковому порядку).
4. Тим, що у розгалуженої програмі є блок перевірки умови, а у лінійної він відсутній.
11
Документ
Категория
Разное
Просмотров
674
Размер файла
178 Кб
Теги
отчёты
1/--страниц
Пожаловаться на содержимое документа